Home Forums WordPress Themes WhiteBlack WP Theme Facebook Social Media

Facebook Social Media

  • Author
    Posts
  • #5286

    sam.james
    Participant

    On my website http://www.swbmx.co.uk when you share the post URL too Facebook the thumbnail image connected too the post does not show up like it should do? how do I fix this?

    Thanks Sam @ SWBMX

    #5287

    Marcin
    Moderator

    Hi,

    if I good understood you do not like images of your posts published on Facebook?
    if I am right you should try use plugin like Yeast SEO to configuration of OG tags.

    regards
    Marcin

    #5294

    sam.james
    Participant

    Hi, i tried this and it didn’t work, I want the featured image on a website post from http://www.swbmx.co.uk too come up on Facebook when you copy and paste the url from the post into the status bar.

    Attachments:
    You must be logged in to view attached files.
    #5296

    Marcin
    Moderator

    Hi,

    for me, everything is fine. For example post http://swbmx.co.uk/richard-perry-welcome-to-blank/ with featured image:

    has OG code <meta property="og:image" content="http://swbmx.co.uk/wp-content/uploads/2016/03/MVI_7573.00_01_35_04.Still001-1.png" /> so after publish this post on Facebook, this image will be publish on the wall

    regards
    Marcin

    #5299

    sam.james
    Participant

    That post works because I have uploaded a image too the post but I don’t want too, it looks untidy that way, there should only be 1 image option not 2, this will cause confusion to viewers so our social media wouldn’t be working correctly, if this isn’t sorted soon you can offer me a refund as your theme isn’t up to a proper standard. try a different post which doesn’t have a image inside the post.

    thanks sam

    #5300

    Marcin
    Moderator

    Facebook use your image you set in Yeast SEO in “facebook image” (og:image) field but image meets FB’s criteria. First of all you need check image size and try 1200 x 628px. (tip from: http://stackoverflow.com/questions/20259142/facebook-open-graph-image-not-displaying).

    Use Facebook Debug to check whether og:image is good in your post.

    regards, Marcin

    #5301

    sam.james
    Participant

    Hi,

    Okay thank you I will check that out later it seems too be working now, 1 last problem is how do i change the Follow me @Instagram part at the bottom too @swbmxcrew?

    Many thanks,
    Sam

    Attachments:
    You must be logged in to view attached files.
    #5303

    Marcin
    Moderator

    This phrase is translatable, so you can overwrite it by PO file.
    But you use website in english version, so maybe easier for you will be change it in template file (\wp-content\themes\whiteblack\templates\footer.php)?

    regards, Marcin

You must be logged in to reply to this topic. Click here to login or register